ENG
≡ Menu
  • 24U Software

Plug-Ins Compatibility

A lot has changed since the release of FileMaker Pro 4 Developer Edition, the first version of FileMaker supporting 3rd party plug-ins. FileMaker’s support for plug-ins is being constantly expanded and enhanced. Unfortunately, this evolution also brings compatibility issues you might be concerned about. This page is supposed to give you an up-to-date overview listing which plug-in version best suits concrete FileMaker Pro version. Here is a brief summary of plug-in compatibilty. Show whole table.
FM Pro 16 Pro
32-bit
16 Pro
64-bit
16 Server 17 Pro
32-bit
17 Pro
64-bit
17 Server
24U Gonector 1.0 1.0 x 1.0 1.0 x
24U Phidgets Plug-In 2.0 2.0 x 2.0 2.0 x
24U Phone Companion 2.1 2.1 x 2.1 2.1 x
24U SimpleChart Plug-In x x x x x x
24U SimpleCode Plug-In x x x x x x
24U SimpleDialog Plug-In 5.0 5.0 x 5.0 5.0 x
24U SimpleFile Plug-In 2.0 3.0 3.0 2.0 3.0 3.0
24U SimpleHASP Plug-In 2.0 2.0 x 2.0 2.0 x
24U SimpleHelp Plug-In none
24U SimpleHighlight Plug-In x x x x x x
24U SimpleSound Plug-In 3.0.1 4.1.4 4.1.4 3.0.1 4.1.4 x
24U SimpleTalk Plug-In 2.0 x x 2.0 x x
24U Toolbox Plug-In 1.3 1.3 1.3 1.3 1.3 1.3
24U VirtualUser Plug-In x x x x x x
24U Plug-In Template see Custom Development or Developer Support
24U Plug-In Autoinstaller not needed
24U Preferences+Globals Plug-In x x x x x x
  Notes:
  • You can see minimal requested versions of the plug-ins for the particular software versions.
  • *Version 1.0 of 24U SimpleCode Plug-In is called 24U Transcoding Plug-In
  • 24U Preferences+Globals Plug-In is an old-style PowerPC plug-in. It will work on PowerPC Macs and Windows. For more info see paragraph below
  • FileMaker Pro 15 on OS X can be run only as a 64-bit application.
There is a big step between FileMaker Pro 6 and 7. All plug-ins were rewritten and adjusted to a new environment. That means plug-in versions for FileMaker Pro 7 will not work in lower versions of FileMaker Pro. On the other hand old-style FM Pro 6 plug-ins will work on higher versions of FM Pro on PowerPC Macs. These plug-ins will work even on Intel-based Macs but only in FileMaker Pro PowerPC binary not in FileMaker Pro universal binary. All plug-in versions compatible with FileMaker Pro 8.5 and above are universal binaries which work natively on both PowerPC and Intel Macs (except 24U Preferences+Globals Plug-In). All plug-ins work on Mac OS X and Windows platforms. All plug-ins are tested on Mac OS X 10.9 and on Windows 8.1 64bit. Please check this page later for up-to-date information.

Making 32-bit plug-ins work with FileMaker Pro 14

On Windows: You can install FileMaker Pro as a 32-bit or 64-bit application in supported 64-bit versions of Windows. Once installed, FileMaker Pro cannot be switched between 32-bit and 64-bit modes on Windows. If you want to switch from the 32-bit version of FileMaker Pro to a 64-bit version of FileMaker Pro on the Windows platform, you must uninstall the currently installed version and re-install using the appropriate 32-bit or 64-bit installer. On Mac OS X:
  • Select the FileMaker Pro application in Finder
  • Choose “Get Info” option from the File menu
  • Enable the “Open in 32-bit mode” option
NOTE:  64-bit application enabled to run in 32-bit mode on OS X will launch in 32-bit mode if launched from the Finder but will still launch in 64-bit mode if launched from the OS X dock. Click here to learn more about compatibility of FileMaker Pro 14 with 32-bit and 64-bit operating systems.
Products Sales Other